WP-Compatibility-Pack Plugin

몇개의 플러그인을 수정하고 만들면서 느꼈던 점이 최근 공개된 워드프레스에 포함된 괜찮은 기능들을 이전 버전에서는 사용할 수 없는 안타까움을 느낌과 동시에, 이전 버전을 지원하기 위한 내용들을 작성하는데 귀찮음을 느끼게 되어 이런 플러그인을 만들게 되었습니다.

이전 버전의 워드프레스를 사용하면서 최근에 공개된 플러그인들을 사용하지 못했던 분들께도 유용한 플러그인이 되지 않을까 합니다. 다만, 플러그인 형태로 모든걸 해결 할 수는 없는지라, 이 플러그인을 통해서도 작동하지 않는 플러그인들도 많으리라 생각됩니다. 새로 추가된 함수나 기능들은 이렇게 플러그인 형태로 적용이 가능하지만, 기존의 함수가 변형된 경우는 pluggable 함수가 아닌이상 파일을 교체하는 방법밖에 없으니까요…:(

지금 계획으로서는 업데이트되거나 새로 공개될 제 플러그인들 모두 이 플러그인을 통해 이전 버전의 워드프레스를 지원할 예정입니다. 아무래도 1.5 버전대 까지 지원하려니 걸리는게 한두가지가 아니더군요.

설치

  • 이 플러그인은 플러그인 파일과 폴더를 업로드하는 위치를 정확하게 지켜주셔야 만이 올바르게 작동합니다. 여타 다른 플러그인이 로드되기 전에 제일 먼저 이 플러그인이 로드되어야 하기 때문이죠.
  • 압축을 풀면 나오는 _compatibility_pack.php 파일과 _compatibility_pack 폴더를 플러그인 폴더에 업로드합니다. wp-content/plugins/_compatibility_pack.php, wp-content/plugins/_compatibility_pack/ 과같은 경로가 맞습니다.
  • 플러그인 관리 화면(WP-Admin>Plugins)에서 “WP-Compatibility-Pack”을 활성화(Activate) 시킵니다.

이전 버전의 워드프레스를 사용하면서 사용하지 못하는 플러그인이 있다면, 워드프레스 버전과 플러그인에 대한 정보를 알려주세요. 많이 사용되는 또는 유용한 플러그인이라면 이 플러그인을 통해 사용 가능하도록 할 수 있는지를 확인해서 업데이트 하도록 하겠습니다. 물론… 제 능력의 테두리 안에 있을 경우에 해당되겠죠…?

1 thought on “WP-Compatibility-Pack Plugin”

Comments are closed.